We all know the problems that Oculus is having with its room-scale tracking and the fact that its just released update (the 1.11) is not helping that much. Nate Mitchell has tried saying that everything is ok and that bad tracking is all fault of bad camera positioning by the users but I don’t believe this that much.

Today I opened a post that was lying around on reddit (ah, the lovely reddit) since some days ago, to discover an absolutely strange but effective solution to these problems.

A genius user, Alehandoro, has published a short guide to fix tracking problems using duct tape (!!!). I know, it’s weird fixing a 698$ super technological device using duct tape, but nothing surprises me anymore. Alehandoro is a OSVR user, so he’s obviously a maker (OSVR is not that user-friendly as the Rift). He says that OSVR had similar tracking problems, until Sensics fixed the firmware, and that these problems were due to some synchronization stuff of the LEDs on the headset. The solution to this? Cover completely the headset LEDs that cause the issues, so that the tracking can start working well. As Alehandoro, says:

It is a very sloppy way to solve it. I was an OSVR user and I had to take the same solution to improve the tracking until I was able to update the firmware of the LED controller.

This problem also appeared in OSVR from the beginning, and was due to a problem in the “blinking” or synchronization of the LEDs that caused jumps to spoil the whole experience.

At the time the publication of the firmware that solved the problem in OSVR consisted in a rewriting of the code of synchronization and the shutdown of certain LEDs of the HMD to facilitate its vision by part of the sensor.

I discovered (it is on reddit in case you want to look for it here ) that plugging those infrared leds with black tape would get practically the same effect as updating the firmware.

And indeed, the same solution I adopted at OSVR has come back to work here until Oculus solves the problem via software.

I think this guy is a genius: I wouldn’t even think a similar solution to the problem. And if you’re having problems with Oculus Tracking and no one of the other solutions seem to work, give this strange idea a try! You can (and must) read the original post here. There you’ll find more info about the workaround and a big debate in the comments (with some users confirming that this works!).

Hope you liked this article… otherwise we can try to fix it with some duct tape, too…